欢迎来到火箭股票配资平台 - 一个安全正规的股票配资咨询平台!
火箭配资:http://www.eratat.cn 专业正规的配资平台,安全可靠放心!
当前位置:股票配资 > 股票配资> 正文

通达信macd指标公式源码大全

  通达信macd公式大全,今天小编要为大家带来和分享的是该指标公式的内容,顶底背离,金叉选股等等公式,相信也是大家在投资过程中有需要的,下面就和火箭配资小编一起来了解看看吧!

  通达信macd底背离选股公式

  DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);

  DEA:=EMA(DIFF,9);

  MACD:=(DIFF-DEA)*2;

  DAYS:=IF(DIFF>DEA,BARSLAST(DIFFDEA));

  AREA0:=SUM(MACD,DAYS);

  AREAM1:=REF(AREA0,DAYS);

  AREAM2:=REF(AREAM1,DAYS);

  AREAM3:=REF(AREAM2,DAYS);

  HPRE:=HHV(L,DAYS);

  HPREM1:=REF(HPRE,DAYS);

  HPREM2:=REF(HPREM1,DAYS);

  HPREM3:=REF(HPREM2,DAYS);

  LPRE:=LLV(L,DAYS);

  LPREM1:=REF(LPRE,DAYS);

  XG:AREAM1>AREAM3 AND HPREM10 ;

通达信macd指标公式源码大全

  通达信macd底背离抄底公式

  DIF:=EMA(C,12)-EMA(C,26);DEA:=EMA(DIF,9);MACD:=2*(DIF-DEA);S05:=SUM(MACD,0);QST:=BARSLAST(MACD<0 and="" style="">0)+1;QXT:=BARSLAST(MACD>0 AND REF(MACD,1)<0)+1; s5:="IF(MACD" style="">0,S05-REF(S05,BARSLAST(MACD<0)),s05-ref(s05,barslast(macd style="">0)))/10;ST:=IF(MACD>0,REF(QST,QXT)+QXT,REF(QXT,QST)+QST);RS5:=REF(S5,ST);BC:IF(MACD>0 AND S5RS5 AND DEA<0,1,0));

  通达信macd顶背离公式

  公式源码:DIFF:EMA(CLOSE,12)-EMA(CLOSE,26);

  DEA:EMA(DIFF,9);

  MACD:2*(DIFF-DEA), COLORSTICK,LINETHICK2;

  JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA >= 0));

  A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

  顶背离:=REF(CLOSE,A2+1) < CLOSE AND REF(DIFF,A2+1) > DIFF AND CROSS(DEA,DIFF);

  DRAWTEXT(顶背离,DIFF,' 顶背离'),COLORGREEN;

  通达信macd顶背离选股公式

  DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);

  DEA:=EMA(DIFF,9);

  MACD:=(DIFF-DEA)*2;

  B:=BARSLAST(REF(CROSS(DEA,DIFF),1));

  顶背:REF(H,B+1)

  零轴上方首次金叉选股公式

  DIF:=EMA(CLOSE,12)-EMA(CLOSE,26); DEA:=EMA(DIF,9); MACD:=(DIF-DEA)*2; 距离范围:=RANGE(DEA,-0.2,0.2); {调整值:-0.2,0.2,扩大或缩小范围} XG:CROSS(DIF,DEA) AND 距离范围; DIF:=EMA(CLOSE,12)-EMA(CLOSE,26); DEA:=EMA(DIF,9); MACD:=(DIF-DEA)*2; XG:CROSS(MACD,-0.05) AND DEA>0;

  空中加油公式

  {0轴上方---空中加油副图}DIF:EMA(CLOSE,12) - EMA(CLOSE,26),colorffffff;DEA:EMA(DIF,9),coloryellow;MACD:2*(DIF-DEA),COLORSTICK;

  控制加油:=COUNT(DIF>DEA,BARSLAST(CROSS(DIF,DEA)))=BARSLAST(CROSS(DIF,DEA))AND CROSS(DIF,REF(DIF,1)) AND MACD>0 AND MACD<0.6 AND DIF>=0 AND DEA>=0 ;DRAWICON(空中加油,DIF,10);DRAWICON(空中加油,DIF-0.5,11);

  0轴上二次金叉选股公式

  JC:IF(SUM(IF(MACD>0 AND CROSS(MACD.DIF,MACD.DEA),1,0),0)-HHV(IF(IF(CROSS(MACD.DEA,0),1,0),

  SUM(IF(MACD>0 AND CROSS(MACD.DIF,MACD.DEA),1,0),0),0),0)=2 AND SUM(IF(MACD>0 AND CROSS(MACD.DIF,MACD.DEA),1,0),

  0)>REF(SUM(IF(MACD>0 AND CROSS(MACD.DIF,MACD.DEA),1,0),0),1),10,0);

  以上,就是一些小编要分享给大家的常用指标公式,希望对大家有用!同时推荐相关知识:【股票配资】缠中说禅选股公式 炒股流程

版权保护: 本文由配资专家原创,本文主要讲述《通达信macd指标公式源码大全》: http://www.eratat.cn/gppz/253.html